granite: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Mar 2016 13:15:45 +0000 (10:15 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Mar 2016 22:33:47 +0000 (23:33 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/granite/Config.in [new file with mode: 0644]
package/granite/granite.hash [new file with mode: 0644]
package/granite/granite.mk [new file with mode: 0644]

index 6e7fffdf1880273ccd2f58aeea96a32f7ea9f96e..1467f33bff93e9e5c4eeb1ead05fab7900f7e9ac 100644 (file)
@@ -887,6 +887,7 @@ menu "Graphics"
        source "package/gdk-pixbuf/Config.in"
        source "package/giblib/Config.in"
        source "package/giflib/Config.in"
+       source "package/granite/Config.in"
        source "package/graphite2/Config.in"
        source "package/gtkmm3/Config.in"
        source "package/harfbuzz/Config.in"
diff --git a/package/granite/Config.in b/package/granite/Config.in
new file mode 100644 (file)
index 0000000..fef5e27
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_GRANITE
+       bool "granite"
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       depends on BR2_PACKAGE_LIBGTK3
+       select BR2_PACKAGE_LIBGEE
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         An extension to GTK+ that provides several useful widgets and
+         classes to ease application development.
+
+         https://launchpad.net/granite
+
+comment "granite needs libgtk3 and a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_PACKAGE_LIBGTK3 || !BR2_USE_WCHAR \
+               || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/granite/granite.hash b/package/granite/granite.hash
new file mode 100644 (file)
index 0000000..5ce95e6
--- /dev/null
@@ -0,0 +1,4 @@
+# From https://launchpad.net/granite/0.3/0.3.1/+download/granite-0.3.1.tar.xz/+md5
+md5    4297d4fcec8cfe2e08b460a45c779bbe        granite-0.3.1.tar.xz
+# Calculated based on the hash above
+sha256 8ec1d61f9aba75f1b3a745e721288b0dfb34cb11d1307be80cef7b0571c2dec6        granite-0.3.1.tar.xz
diff --git a/package/granite/granite.mk b/package/granite/granite.mk
new file mode 100644 (file)
index 0000000..dd5a09e
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# granite
+#
+################################################################################
+
+GRANITE_VERSION_MAJOR = 0.3
+GRANITE_VERSION = $(GRANITE_VERSION_MAJOR).1
+GRANITE_SITE = https://launchpad.net/granite/$(GRANITE_VERSION_MAJOR)/$(GRANITE_VERSION)/+download
+GRANITE_SOURCE = granite-$(GRANITE_VERSION).tar.xz
+GRANITE_DEPENDENCIES = host-pkgconf host-vala libgee libglib2 libgtk3
+GRANITE_INSTALL_STAGING = YES
+GRANITE_LICENSE = LGPLv3+
+GRANITE_LICENSE_FILES = COPYING
+
+$(eval $(cmake-package))