autossh: fix manual set of ssh path
authorBaruch Siach <baruch@tkos.co.il>
Thu, 14 Jun 2018 18:38:48 +0000 (21:38 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Jun 2018 11:13:58 +0000 (13:13 +0200)
The configure script that is bundled with autossh does not generate the
correct code for the AC_ARG_WITH() macro of --with-ssh. As a result, the
configure scripts always check the host location, and fails with ssh is
not found.

Restore the autoreconf that has been removed in the last bump to fix the
--with-ssh configure option.

Fixes:
http://autobuild.buildroot.net/results/25d/25d681f9df22c07cdf5a6b8756bfc2d5ecf36247/
http://autobuild.buildroot.net/results/f0a/f0ae62d0ed6bac011c507cfea7cd7157671baf39/
http://autobuild.buildroot.net/results/b15/b1546bb3e861c14771bdd03cda9ce2e9176a2069/

Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/autossh/autossh.mk

index 1538a4c8bcfbda3cbc3438eff783dc9712172c3c..5af8b735c2e0e70d919fb102176fd68b0973612e 100644 (file)
@@ -9,6 +9,8 @@ AUTOSSH_SITE = http://www.harding.motd.ca/autossh
 AUTOSSH_SOURCE = autossh-$(AUTOSSH_VERSION).tgz
 AUTOSSH_LICENSE = Modified BSD
 AUTOSSH_LICENSE_FILES = autossh.c
+# Fix AC_ARG_WITH code generation for --with-ssh
+AUTOSSH_AUTORECONF = YES
 
 AUTOSSH_CONF_OPTS = --with-ssh=/usr/bin/ssh