Add lcdproc config options, for driver selection
authorspdawson@gmail.com <spdawson@gmail.com>
Wed, 11 Apr 2012 12:12:30 +0000 (13:12 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 May 2012 20:22:10 +0000 (22:22 +0200)
Add a configuration menu item to specify a list of lcdproc drivers to
be built. The list defaults to 'all'.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lcdproc/Config.in
package/lcdproc/lcdproc.mk

index 6c8614d6d756e772018a2dc64350047bd43bf66b..72611056a1196b8c6d9f0f59ff54a6d2adaf53ac 100644 (file)
@@ -5,3 +5,10 @@ config BR2_PACKAGE_LCDPROC
          LCD display driver daemon and clients
 
          http://lcdproc.org/
+
+config BR2_PACKAGE_LCDPROC_DRIVERS
+       string "List of drivers to build"
+       default "all"
+       depends on BR2_PACKAGE_LCDPROC
+       help
+         Specify a comma-separated list of lcdproc drivers to be built
index e8919e9c867cf8c953c44ae7d62d481ae2cad6de..745b38616150d51ada2484457104931a938ab0bb 100644 (file)
@@ -7,7 +7,7 @@ LCDPROC_VERSION = 0.5.5
 LCDPROC_SOURCE = lcdproc-$(LCDPROC_VERSION).tar.gz
 LCDPROC_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/lcdproc/lcdproc/$(LCDPROC_VERSION)
 
-LCDPROC_CONF_OPT = --enable-drivers=all
+LCDPROC_CONF_OPT = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS)
 
 LCDPROC_DEPENDENCIES = ncurses