package: add fmtools
authorMarek Belisko <marek.belisko@open-nandra.com>
Sun, 1 Apr 2012 12:18:43 +0000 (14:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 8 Apr 2012 07:41:58 +0000 (09:41 +0200)
[Peter: fix install, help text]
Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/fmtools/Config.in [new file with mode: 0644]
package/fmtools/fmtools.mk [new file with mode: 0644]

index c895cc14a40cf922a2e90313759f31a329a71875..4c6d4d87f3d605a28edb63264a618e1fd9911c3d 100644 (file)
@@ -174,6 +174,7 @@ source "package/e2fsprogs/Config.in"
 source "package/eeprog/Config.in"
 source "package/fconfig/Config.in"
 source "package/fis/Config.in"
+source "package/fmtools/Config.in"
 source "package/gadgetfs-test/Config.in"
 source "package/gdisk/Config.in"
 source "package/genext2fs/Config.in"
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644 (file)
index 0000000..1591618
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_FMTOOLS
+       bool "fmtools"
+       help
+         fmtools is a pair of simple command-line utilities for
+         "video4linux" radio tuner cards under Linux. It includes
+         fm for power control, tuning, and volume and fmscan for
+         scanning for stations.
+
+         http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644 (file)
index 0000000..f705173
--- /dev/null
@@ -0,0 +1,19 @@
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin/fm
+       $(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin/fmscan
+endef
+
+$(eval $(call GENTARGETS))