gettext: fix static build failure
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 19 Jan 2013 02:06:25 +0000 (02:06 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Jan 2013 08:54:25 +0000 (09:54 +0100)
When static libraries are preferred we don't build dynamic libraries so
it fails on the install phase. So don't try to do it for those cases.
Fixes:
http://autobuild.buildroot.net/results/651537ae1909b039e0cfc5c104ee87f93a9e5792/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gettext/gettext.mk

index 953077d21a050a73ac4da1fd23f127dc42910568..204af1089126b0d97e9824436ebb286c47b2c59b 100644 (file)
@@ -35,9 +35,12 @@ endif
 # When the gettext tools are not enabled in the configuration, we only
 # install libintl to the target.
 ifeq ($(BR2_PACKAGE_GETTEXT_TOOLS),)
+# When static libs are preferred the .so files aren't created
+ifeq ($(BR2_PREFER_STATIC_LIB),)
 define GETTEXT_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libintl*.so* $(TARGET_DIR)/usr/lib/
 endef
+endif
 # Ditch the tools since they're off and pull other dependencies
 define GETTEXT_DISABLE_TOOLS
        $(SED) 's/runtime gettext-tools/runtime/' $(@D)/Makefile.in