qt: remove TARGET_CONFIGURE_OPTS from make invocation
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:29 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:37:05 +0000 (14:37 +0200)
All compiler options, switches and path settings are done in the
configure step. For the compile and install step there is no need
for the TARGET_CONFIGURE_OPTS variables.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 47b5feb1a51c017a2ed601198e8dd138be149722..09a027df243eb35a2f0fe1a0a001b9b012c2bf64 100644 (file)
@@ -474,11 +474,11 @@ endif
        touch $@
 
 $(QT_TARGET_DIR)/.compiled: $(QT_TARGET_DIR)/.configured
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(QT_TARGET_DIR)
+       $(MAKE) -C $(QT_TARGET_DIR)
        touch $@
 
 $(STAGING_DIR)/usr/lib/libQtCore.la: $(QT_TARGET_DIR)/.compiled
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(QT_TARGET_DIR) install
+       $(MAKE) -C $(QT_TARGET_DIR) install
 
 qt-gui: $(STAGING_DIR)/usr/lib/libQtCore.la
        mkdir -p $(TARGET_DIR)/usr/lib/fonts