package/piglit: set python executable
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 3 Nov 2019 08:55:20 +0000 (09:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 4 Nov 2019 21:35:32 +0000 (22:35 +0100)
Without this change, piglit will detect and use python from host
resulting in build failures if python-mako, python-numpy or python-six
are not installed

Fixes:
 - http://autobuild.buildroot.org/results/8d782589b6073031626fd769982a0844f3731906

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/piglit/piglit.mk

index 4f95e77cfd7e5b74b08dd3b6d9dc8080b33e090d..d4753b9f7aa605ba264b3a835ed174ff6ddefe4d 100644 (file)
@@ -29,7 +29,8 @@ PIGLIT_DEPENDENCIES = host-pkgconf \
 PIGLIT_CONF_OPTS += \
        -DPIGLIT_USE_WAFFLE=ON \
        -DPIGLIT_BUILD_CL_TESTS=OFF \
-       -DPIGLIT_BUILD_WGL_TESTS=OFF
+       -DPIGLIT_BUILD_WGL_TESTS=OFF \
+       -DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 # libxcb for xcb-dri2