package/eigen: install .pc file
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 28 Dec 2015 19:08:54 +0000 (20:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Dec 2015 20:58:14 +0000 (21:58 +0100)
Other packages will look for eigen3.pc to detect the presence of eigen3.

eigen3.pc is usually installed by eigen's cmake buildsystem, but we do a
manual install to not depend on host-cmake just to install header files.
But in doing so, we forgot to install the .pc file.

Manually sed the source .pc.in to generate the final .pc file.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/eigen/eigen.mk

index dd88fde45fef1e7ccf430d198c00f74c9e9fd66e..3eb858ad8dd92509b2d774417301da5d28f7b090 100644 (file)
@@ -20,6 +20,13 @@ define EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS
 endef
 endif
 
+# Generate the .pc file at build time
+define EIGEN_BUILD_CMDS
+       sed -r -e 's,^Version: .*,Version: $(EIGEN_VERSION),' \
+              -e 's,^Cflags: .*,Cflags: -I$(EIGEN_DEST_DIR),' \
+              $(@D)/eigen3.pc.in >$(@D)/eigen3.pc
+endef
+
 # This package only consists of headers that need to be
 # copied over to the sysroot for compile time use
 define EIGEN_INSTALL_STAGING_CMDS
@@ -27,6 +34,8 @@ define EIGEN_INSTALL_STAGING_CMDS
        mkdir -p $(EIGEN_DEST_DIR)
        cp -a $(@D)/Eigen $(EIGEN_DEST_DIR)
        $(EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS)
+       $(INSTALL) -D -m 0644 $(@D)/eigen3.pc \
+                             $(STAGING_DIR)/usr/lib/pkgconfig/eigen3.pc
 endef
 
 $(eval $(generic-package))