makedevs: change version from 'undefined' to 'buildroot-$(BR2_VERSION)'
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 11 Jun 2014 19:12:28 +0000 (21:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Jun 2014 17:10:18 +0000 (19:10 +0200)
The sources of the makedevs package are shipped with Buildroot, rather than
downloaded from an external location. As a result, no explicit version is
defined, causing build messages and build directory to show 'undefined' as
version.

This patch sets the version for makedevs to 'buildroot-$(BR2_VERSION), which
would for example expand to 'buildroot-2014.05'.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/makedevs/makedevs.mk

index ff91c4a896596ffdb18f8ca54e76de638a2e09bd..7210dc6c2545c1401cbdc9bb1b4ee992d55a929d 100644 (file)
@@ -8,6 +8,8 @@
 MAKEDEVS_SOURCE =
 HOST_MAKEDEVS_SOURCE =
 
+MAKEDEVS_VERSION = buildroot-$(BR2_VERSION)
+
 define MAKEDEVS_BUILD_CMDS
        $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
                package/makedevs/makedevs.c -o $(@D)/makedevs