package/audit: bear the kernel options munging
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Apr 2020 12:10:22 +0000 (14:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 1 May 2020 13:50:28 +0000 (15:50 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Adam Duskett <aduskett@gmail.com>
Cc: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/linux.mk
package/audit/audit.mk

index eb13920d57f912f84a5a2690bd2a51bbd0320e71..e0a69444eb61ff3b857de285e7a8dafd1b502906 100644 (file)
@@ -355,9 +355,6 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET))
-       $(if $(BR2_PACKAGE_AUDIT),
-               $(call KCONFIG_ENABLE_OPT,CONFIG_NET)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_AUDIT))
        $(if $(BR2_PACKAGE_INTEL_MICROCODE),
                $(call KCONFIG_ENABLE_OPT,CONFIG_MICROCODE)
                $(call KCONFIG_ENABLE_OPT,CONFIG_MICROCODE_INTEL))
index 03967ee6502f352d1bd46e692c4bd0c0f041db42..652e0fcd5611724b6b8b5137ccf4014a5c4de991 100644 (file)
@@ -54,6 +54,11 @@ define AUDIT_INSTALL_CLEANUP
 endef
 AUDIT_POST_INSTALL_TARGET_HOOKS += AUDIT_INSTALL_CLEANUP
 
+define AUDIT_LINUX_CONFIG_FIXUPS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NET)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_AUDIT)
+endef
+
 HOST_AUDIT_CONF_OPTS = \
        --without-python \
        --without-python3 \