Fix the Python build when running Linux 3.*
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Fri, 12 Aug 2011 12:22:56 +0000 (14:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 14 Aug 2011 06:52:13 +0000 (08:52 +0200)
When compiling Python on a host running Linux 3.0, the sys.platform
constant is set at "linux3". A lot of code (inside the interpreter
itself, its build system and third party apps and libraries) relies on
it to be linux2 on a Linux system.

This leads to the build of the target python package to break.

This behaviour has been reported on the Python bugtracker but is not
fixed yet.

http://bugs.python.org/issue12326

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/python/python-2.7-013-fix-linux-3-compilation.patch [new file with mode: 0644]

diff --git a/package/python/python-2.7-013-fix-linux-3-compilation.patch b/package/python/python-2.7-013-fix-linux-3-compilation.patch
new file mode 100644 (file)
index 0000000..a43ec7e
--- /dev/null
@@ -0,0 +1,22 @@
+diff -r 683202530137 configure
+--- a/configure        Fri Aug 12 11:40:39 2011 +0300
++++ b/configure        Fri Aug 12 14:02:18 2011 +0200
+@@ -3055,6 +3055,7 @@ then
+       cygwin*) MACHDEP="cygwin";;
+       darwin*) MACHDEP="darwin";;
+         irix646) MACHDEP="irix6";;
++        linux*) MACHDEP="linux2";;
+       '')     MACHDEP="unknown";;
+       esac
+ fi
+diff -r 683202530137 configure.in
+--- a/configure.in     Fri Aug 12 11:40:39 2011 +0300
++++ b/configure.in     Fri Aug 12 14:02:18 2011 +0200
+@@ -307,6 +307,7 @@ then
+       cygwin*) MACHDEP="cygwin";;
+       darwin*) MACHDEP="darwin";;
+         irix646) MACHDEP="irix6";;
++        linux*) MACHDEP="linux2";;
+       '')     MACHDEP="unknown";;
+       esac
+ fi