package/pkg-generic: mark some rule PHONY
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 22 Mar 2019 21:07:05 +0000 (22:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 25 Mar 2019 18:27:04 +0000 (19:27 +0100)
The %-graph-rdepends should be marked PHONY, as the %-graph-depends is.

The %-show-dependency-tree should also be a PHONY rule, because it does
not actually create a file. Furthermore, to avoid the "Nothing to be
done for .." message, give that rule an actual recipe that just does
nothing.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-generic.mk

index db7f06ddbe3c3c6152b4ad261e73b9b5e9592162..dd3e20ca574cae7fb90d67da1b172d4883fe2f91 100644 (file)
@@ -859,6 +859,7 @@ $(1)-show-build-order: $$(patsubst %,%-show-build-order,$$($(2)_FINAL_ALL_DEPEND
        $$(info $(1))
 
 $(1)-show-dependency-tree: $$(patsubst %,%-show-dependency-tree,$$($(2)_FINAL_ALL_DEPENDENCIES))
+       @:
        $$(info $(1): $(4) $$(if $$($(2)_IS_VIRTUAL),virtual,$$($(2)_DL_VERSION)))
        $$(info $(1) -> $$(foreach d,$$($(2)_FINAL_ALL_DEPENDENCIES),$$(d)))
 
@@ -1079,6 +1080,7 @@ DL_TOOLS_DEPENDENCIES += $$(call extractor-dependency,$$($(2)_SOURCE))
        $(1)-external-deps \
        $(1)-extract \
        $(1)-graph-depends \
+       $(1)-graph-rdepends \
        $(1)-install \
        $(1)-install-host \
        $(1)-install-images \
@@ -1091,6 +1093,7 @@ DL_TOOLS_DEPENDENCIES += $$(call extractor-dependency,$$($(2)_SOURCE))
        $(1)-reconfigure \
        $(1)-reinstall \
        $(1)-rsync \
+       $(1)-show-dependency-tree \
        $(1)-show-depends \
        $(1)-show-version \
        $(1)-source