package/swig: enable PCRE regex matching in host-swig
authorRomain Naour <romain.naour@gmail.com>
Wed, 29 May 2019 15:16:54 +0000 (17:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Jun 2019 07:23:52 +0000 (09:23 +0200)
The upcoming ogre package needs a host swig binary with PCRE
regex support.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/swig/swig.mk

index 157d3a39a69cf9d94d984a87b6a3e2d8bfa6c730..892b0abe30857377e4192857474b20ec20fc861e 100644 (file)
@@ -7,9 +7,9 @@
 SWIG_VERSION_MAJOR = 3.0
 SWIG_VERSION = $(SWIG_VERSION_MAJOR).12
 SWIG_SITE = http://downloads.sourceforge.net/project/swig/swig/swig-$(SWIG_VERSION)
-HOST_SWIG_DEPENDENCIES = host-bison
+HOST_SWIG_DEPENDENCIES = host-bison host-pcre
 HOST_SWIG_CONF_OPTS = \
-       --without-pcre \
+       --with-pcre \
        --disable-ccache \
        --without-octave
 SWIG_LICENSE = GPL-3.0+, BSD-2-Clause, BSD-3-Clause