package/transmission: drop second patch
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 17 Oct 2020 19:46:39 +0000 (21:46 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Oct 2020 21:58:21 +0000 (23:58 +0200)
transmission in version 3.00 is building fine on musl and upstream
thinks that this patch is not needed anymore:
https://github.com/transmission/transmission/pull/1156

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/transmission/0002-fix-utp-include.patch [new file with mode: 0644]
package/transmission/0002-musl-missing-header.patch [deleted file]
package/transmission/0003-fix-utp-include.patch [deleted file]

diff --git a/package/transmission/0002-fix-utp-include.patch b/package/transmission/0002-fix-utp-include.patch
new file mode 100644 (file)
index 0000000..db8b5ab
--- /dev/null
@@ -0,0 +1,46 @@
+Fix compilation when using system libminiupnpc with libutp disabled
+
+If transmission uses its own copy of libminiupnpc in third-party/ then
+the configure script adds that path to CFLAGS:
+https://trac.transmissionbt.com/browser/trunk/configure.ac#L455
+
+This path is also added if transmission uses its own copy of libutp:
+https://trac.transmissionbt.com/browser/trunk/configure.ac#L349
+
+But if a system-provided libminiupnpc is used and utp-support is
+disabled using --disable-utp the result is a build error, detected by
+buildroot autobuilders:
+http://autobuild.buildroot.net/results/b79/b79e51140cb0320554a58ce59dcb33f53cd9211a/build-end.log
+
+net.c:40:24: fatal error: libutp/utp.h: No such file or directory
+
+Patch proposed by Yann E. MORIN:
+http://lists.busybox.net/pipermail/buildroot/2016-July/167896.html
+
+Patch sent upstream: https://trac.transmissionbt.com/ticket/6163
+
+Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
+
+diff -uNr transmission-2.92.org/configure.ac transmission-2.92/configure.ac
+--- transmission-2.92.org/configure.ac 2016-03-06 21:23:45.336198393 +0100
++++ transmission-2.92/configure.ac     2016-07-31 12:13:40.921660078 +0200
+@@ -358,6 +358,10 @@
+     else
+       AC_MSG_ERROR("Unable to build uTP support -- C++ compiler not found")
+     fi
++else
++    # For the system libminiupnpc with UTC disabled,
++    # point to our bundled UTP headers
++    LIBUTP_CFLAGS="-I\$(top_srcdir)/third-party/"
+ fi
+ AC_SUBST(LIBUTP_CFLAGS)
+ AC_SUBST(LIBUTP_LIBS)
+@@ -457,7 +461,7 @@
+     LIBUPNP_LIBS_QT="\$\${TRANSMISSION_TOP}/third-party/miniupnp/libminiupnp.a"
+ else
+     AC_DEFINE([SYSTEM_MINIUPNP])
+-    LIBUPNP_CFLAGS="" 
++    LIBUPNP_CFLAGS="${LIBUTP_CFLAGS}"
+     LIBUPNP_LIBS="-lminiupnpc"
+     LIBUPNP_LIBS_QT="-lminiupnpc"
+ fi
diff --git a/package/transmission/0002-musl-missing-header.patch b/package/transmission/0002-musl-missing-header.patch
deleted file mode 100644 (file)
index ebb74cb..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix musl build
-
-Downloaded from
-https://cgit.gentoo.org/proj/musl.git/tree/net-p2p/transmission/files/transmission-2.84-musl-missing-header.patch
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-
-libtransmission/transmission.h: add missing <sys/types.h>
-
-transmission.h and several files including it, like bitfield.c and fdlimits.h
-make reference to ssize_t, off_t and other types defined in <sys/types.h> but
-never include the header.  By including <sys/types.h> in transmission.h, the
-required type definitions are propagated to all files that need them.
-
-Not including <sys/types.h> on glibc and uClibc systems does not pose a problem
-because of the way the headers stack in those C Standard Libraries, but on musl
-excluding <sys/types.h> leads to compile time failure.
-
-For the POSIX specs, see
-
-http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/sys_types.h.html
-
-Signed-of-by: Anthony G. Basile <blueness@gentoo.org>
-
-diff -Naur transmission-2.84.orig/libtransmission/transmission.h transmission-2.84/libtransmission/transmission.h
---- transmission-2.84.orig/libtransmission/transmission.h      2014-07-01 13:09:01.682910744 -0400
-+++ transmission-2.84/libtransmission/transmission.h   2015-07-19 03:11:07.379219181 -0400
-@@ -28,6 +28,7 @@
- #include <inttypes.h> /* uintN_t */
- #include <time.h> /* time_t */
-+#include <sys/types.h>
- #ifdef WIN32
-  #define __USE_MINGW_ANSI_STDIO 1
diff --git a/package/transmission/0003-fix-utp-include.patch b/package/transmission/0003-fix-utp-include.patch
deleted file mode 100644 (file)
index db8b5ab..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix compilation when using system libminiupnpc with libutp disabled
-
-If transmission uses its own copy of libminiupnpc in third-party/ then
-the configure script adds that path to CFLAGS:
-https://trac.transmissionbt.com/browser/trunk/configure.ac#L455
-
-This path is also added if transmission uses its own copy of libutp:
-https://trac.transmissionbt.com/browser/trunk/configure.ac#L349
-
-But if a system-provided libminiupnpc is used and utp-support is
-disabled using --disable-utp the result is a build error, detected by
-buildroot autobuilders:
-http://autobuild.buildroot.net/results/b79/b79e51140cb0320554a58ce59dcb33f53cd9211a/build-end.log
-
-net.c:40:24: fatal error: libutp/utp.h: No such file or directory
-
-Patch proposed by Yann E. MORIN:
-http://lists.busybox.net/pipermail/buildroot/2016-July/167896.html
-
-Patch sent upstream: https://trac.transmissionbt.com/ticket/6163
-
-Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
-
-diff -uNr transmission-2.92.org/configure.ac transmission-2.92/configure.ac
---- transmission-2.92.org/configure.ac 2016-03-06 21:23:45.336198393 +0100
-+++ transmission-2.92/configure.ac     2016-07-31 12:13:40.921660078 +0200
-@@ -358,6 +358,10 @@
-     else
-       AC_MSG_ERROR("Unable to build uTP support -- C++ compiler not found")
-     fi
-+else
-+    # For the system libminiupnpc with UTC disabled,
-+    # point to our bundled UTP headers
-+    LIBUTP_CFLAGS="-I\$(top_srcdir)/third-party/"
- fi
- AC_SUBST(LIBUTP_CFLAGS)
- AC_SUBST(LIBUTP_LIBS)
-@@ -457,7 +461,7 @@
-     LIBUPNP_LIBS_QT="\$\${TRANSMISSION_TOP}/third-party/miniupnp/libminiupnp.a"
- else
-     AC_DEFINE([SYSTEM_MINIUPNP])
--    LIBUPNP_CFLAGS="" 
-+    LIBUPNP_CFLAGS="${LIBUTP_CFLAGS}"
-     LIBUPNP_LIBS="-lminiupnpc"
-     LIBUPNP_LIBS_QT="-lminiupnpc"
- fi