package/libwebsockets: remove dependency on mmu
authorAdam Duskett <Aduskett@gmail.com>
Sun, 26 Jul 2020 02:28:57 +0000 (19:28 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 Jul 2020 07:10:18 +0000 (09:10 +0200)
Six years ago, commit b6b5bb518d28850e024b90db1129b7f86e9d416c added the MMU
dependency for the libwebsockets package. However, according to the git
history of the CMakeLists.txt file, libwebsockets has supported the vfork
function for at least the last five years.

After testing with the qemu_arm_versatile_nommu_defconfig and the
br-arm-cortex-m4-full.config file, no errors occurred when building
libwebsockets without MMU support.

Remove the dependency; it is no longer necessary. Update the reverse
dependencies as needed.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/janus-gateway/Config.in
package/libwebsockets/Config.in
package/ttyd/Config.in

index 136e6f0b20b25fddb221e271be3fa7e3f8b35d23..434ea30152ddb6bdff43778117abb66993746325 100644 (file)
@@ -84,7 +84,6 @@ config BR2_PACKAGE_JANUS_GATEWAY_UNIX_SOCKETS
 
 config BR2_PACKAGE_JANUS_GATEWAY_WEBSOCKETS
        bool "WebSockets"
-       depends on BR2_USE_MMU
        select BR2_PACKAGE_LIBWEBSOCKETS
 
 endif
index 2b350bf38982f36ee3e77e1e5c4e494baa204705..1d927bb4eaac2da4d099abd5c05b2aa8209255b5 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_LIBWEBSOCKETS
        bool "libwebsockets"
-       depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_ZLIB
        help
          Libwebsockets is a lightweight pure C library built to use
index 23d188e6501ee45249282e1003260d749de6d0a2..df710fbac3633551f87d4fdb1e99fa43fe206fab 100644 (file)
@@ -3,7 +3,7 @@ config BR2_PACKAGE_TTYD
        depends on !BR2_STATIC_LIBS # libuv
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # libuv
        depends on BR2_TOOLCHAIN_HAS_SYNC_4 # libuv, json-c
-       depends on BR2_USE_MMU # libuv, libwebsockets
+       depends on BR2_USE_MMU # libuv
        select BR2_PACKAGE_JSON_C
        select BR2_PACKAGE_LIBUV
        select BR2_PACKAGE_LIBWEBSOCKETS