package/freetype/freetype.mk: Fix editing of freetype-config
authorDaniel Laird <danieljlaird@hotmail.com>
Fri, 16 Jan 2009 09:02:51 +0000 (09:02 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Fri, 16 Jan 2009 09:02:51 +0000 (09:02 -0000)
Found that the editing of freetypr-config was not quite enough.
Changed it and looked at freetype-config --cflags, --libs and got the values
I expected.

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
package/freetype/freetype.mk

index 7659a3a609c920e2666b15f93b3b77c8b38fb813..360d666115edac3d7224a59ee3dde929427e6401 100644 (file)
@@ -17,7 +17,10 @@ $(eval $(call AUTOTARGETS,package,freetype))
 $(FREETYPE_TARGET_INSTALL_TARGET):
        -cp -a $(FREETYPE_DIR)/objs/.libs/libfreetype.so* $(TARGET_DIR)/usr/lib/
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libfreetype.so
-       $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(FREETYPE_DIR)/builds/unix/freetype-config
-       $(SED) "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" $(FREETYPE_DIR)/builds/unix/freetype-config
+       $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
+               -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
+               -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include/freetype2\',g" \
+               -e "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" \
+               $(STAGING_DIR)/usr/bin/freetype-config
        touch $@