gdb: apply post-patch hook on both the host and target builds
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 May 2013 13:03:45 +0000 (13:03 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 May 2013 18:50:15 +0000 (20:50 +0200)
When a Xtensa specific patch needs to be applied, it should be applied
both when doing the target and the host build.

This change is part of the effort to remove the differences between
host and target post-extract and post-patch hooks, that are
problematic for the out-of-tree support.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gdb/gdb.mk

index 398ef7bbe87d63df8b4308d3108c5745213ac578..5f4a7534f2f5ef7f966d64121b107987f6203c9d 100644 (file)
@@ -48,6 +48,7 @@ define GDB_XTENSA_PRE_PATCH
        tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(XTENSA_CORE_NAME).tar \
                -C $(@D) --strip-components=1 gdb
 endef
+GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 HOST_GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 endif