package: add read-edid
authorDimitry Golubovsky <golubovsky@gmail.com>
Sat, 5 May 2012 16:05:18 +0000 (16:05 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 May 2012 07:51:00 +0000 (09:51 +0200)
[Peter: fixup whitespace]
Signed-off-by: Dmitry <golubovsky@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/read-edid/Config.in [new file with mode: 0644]
package/read-edid/read-edid.mk [new file with mode: 0644]

index 6caca9da4f4d34352f77f311532efb8e37363e5d..94d0fb47f0718c146f05dbb8e98de59db7571739 100644 (file)
@@ -211,6 +211,7 @@ source "package/openocd/Config.in"
 source "package/parted/Config.in"
 source "package/pciutils/Config.in"
 source "package/picocom/Config.in"
+source "package/read-edid/Config.in"
 source "package/rng-tools/Config.in"
 source "package/sane-backends/Config.in"
 source "package/sdparm/Config.in"
diff --git a/package/read-edid/Config.in b/package/read-edid/Config.in
new file mode 100644 (file)
index 0000000..bdcb7a7
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_READ_EDID
+       bool "read-edid"
+       depends on BR2_i386
+       help
+         Read-edid is a pair of tools for reading the EDID from a
+         monitor.  It should work with most monitors made since 1996
+         (except for newer ones with 256-byte EDID's - WiP), assuming
+         the video card supports the standard read commands (most
+         do).  Read-edid is a set of two tools - get-edid, which gets
+         the raw edid information from the monitor, and parse-edid,
+         which turns the raw binary information into an
+         XF86Config-compatible monitor section.
+
+         http://polypux.org/projects/read-edid/
diff --git a/package/read-edid/read-edid.mk b/package/read-edid/read-edid.mk
new file mode 100644 (file)
index 0000000..b568d5b
--- /dev/null
@@ -0,0 +1,19 @@
+############################################
+#
+# read-edid
+#
+############################################
+
+READ_EDID_VERSION = 1.4.2
+READ_EDID_SITE = http://www.polypux.org/projects/read-edid/
+
+define READ_EDID_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define READ_EDID_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/get-edid $(TARGET_DIR)/sbin/get-edid
+       $(INSTALL) -D -m 0755 $(@D)/parse-edid $(TARGET_DIR)/sbin/parse-edid
+endef
+
+$(eval $(call AUTOTARGETS))