package/file: add bzip2 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 31 Jan 2020 18:05:44 +0000 (19:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Feb 2020 09:27:32 +0000 (10:27 +0100)
bzip2 is an optional dependency since version 5.38 and
https://github.com/file/file/commit/b259a07ea95827f565faa20f0316e5b2704064f7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/file/file.mk

index 8d0968e6b2dbe6351241570039179e0db2d6cc39..ffa8b8b905fbf1aa6a511b23f421aa5de9c5e3b5 100644 (file)
@@ -14,6 +14,13 @@ FILE_LICENSE = BSD-2-Clause, BSD-4-Clause (one file), BSD-3-Clause (one file)
 FILE_LICENSE_FILES = COPYING src/mygetopt.h src/vasprintf.c
 HOST_FILE_CONF_OPTS = --disable-libseccomp
 
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+FILE_CONF_OPTS += --enable-bzlib
+FILE_DEPENDENCIES += bzip2
+else
+FILE_CONF_OPTS += --disable-bzlib
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
 FILE_CONF_OPTS += --enable-libseccomp
 FILE_DEPENDENCIES += libseccomp