Cleanup libxml2 directory structure
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 23 Sep 2007 14:23:16 +0000 (14:23 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 23 Sep 2007 14:23:16 +0000 (14:23 -0000)
package/libxml2/libxml2.mk

index b4b805ea40eaf50947f12e4190ea97769e7f0e07..412f2ec7b71d042b3c1f3c56a2ec0941844bf43b 100644 (file)
@@ -65,16 +65,23 @@ $(TARGET_DIR)/usr/lib/libxml2.a: $(STAGING_DIR)/usr/lib/libxml2.so
 
 libxml2: uclibc $(TARGET_DIR)/usr/lib/libxml2.so libxml2-headers
 
-$(STAGING_DIR)/usr/include/libxml: $(TARGET_DIR)/usr/lib/libxml2.so
+$(STAGING_DIR)/usr/include/libxml2: $(TARGET_DIR)/usr/lib/libxml2.so
        cp -af $(LIBXML2_DIR)/include/libxml $(STAGING_DIR)/usr/include/libxml2
+       touch -c $@
 
 $(TARGET_DIR)/usr/include/libxml2: libxml2-headers
-       cp -af $(LIBXML2_DIR)/include/libxml $(TARGET_DIR)/usr/include/libxml2
+       cp -af $(LIBXML2_DIR)/usr/include/libxml2 $(TARGET_DIR)/usr/include/libxml2
+       touch -c $@
 
+$(TARGET_DIR)/usr/include/libxml: libxml2-headers
+       ln -s libxml2/libxml $(LIBXML2_DIR)/usr/include/libxml
+       touch -c $@
 
-libxml2-headers: $(STAGING_DIR)/usr/include/libxml
+libxml2-headers: $(STAGING_DIR)/usr/include/libxml2
 
-libxml2-target-headers: $(TARGET_DIR)/usr/include/libxml2 $(TARGET_DIR)/usr/lib/libxml2.a
+libxml2-target-headers: $(TARGET_DIR)/usr/include/libxml2 \
+       $(TARGET_DIR)/usr/include/libxml2 \
+       $(TARGET_DIR)/usr/lib/libxml2.a
 
 libxml2-source: $(DL_DIR)/$(LIBXML2_SOURCE)