package: add jamvm jvm
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Dec 2012 18:02:25 +0000 (10:02 -0800)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Dec 2012 18:21:45 +0000 (10:21 -0800)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/jamvm/Config.in [new file with mode: 0644]
package/jamvm/jamvm.mk [new file with mode: 0644]

index 66e8352505d6a7e447ad5430e493891cac29aef3..f95e29d3deb39ebef3b1bc8f81ba73706c89b347 100644 (file)
@@ -268,6 +268,7 @@ endmenu
 menu "Interpreter languages and scripting"
 source "package/erlang/Config.in"
 source "package/haserl/Config.in"
+source "package/jamvm/Config.in"
 source "package/lua/Config.in"
 source "package/luajit/Config.in"
 if BR2_PACKAGE_LUA || BR2_PACKAGE_LUAJIT
diff --git a/package/jamvm/Config.in b/package/jamvm/Config.in
new file mode 100644 (file)
index 0000000..852c6e8
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_JAMVM
+       bool "jamvm"
+       select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_CLASSPATH
+       help
+         JamVM is a new Java Virtual Machine which conforms to the
+         JVM specification version 2 (blue book).
+
+         http://jamvm.sf.net
diff --git a/package/jamvm/jamvm.mk b/package/jamvm/jamvm.mk
new file mode 100644 (file)
index 0000000..f0765d7
--- /dev/null
@@ -0,0 +1,11 @@
+JAMVM_VERSION = 1.5.4
+JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
+JAMVM_DEPENDENCIES = zlib classpath
+# int inlining seems to crash jamvm, don't build shared version of internal lib
+JAMVM_CONF_OPT = \
+       --with-classpath-install-dir=/usr \
+       --disable-int-inlining \
+       --disable-shared \
+       --without-pic
+
+$(eval $(autotools-package))