tcpreplay: fix static link with libpcap
authorBaruch Siach <baruch@tkos.co.il>
Tue, 29 Mar 2016 18:24:15 +0000 (21:24 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Mar 2016 18:26:28 +0000 (20:26 +0200)
The tcpreplay configure script does not look for static libpcap.a unless
dynamic link is disabled.

Fixes:
http://autobuild.buildroot.net/results/e7e/e7e7744ac0a22eded05f237e40b0cdaeec4ce005/
http://autobuild.buildroot.net/results/3e3/3e33a67965eb37471ec3303ee26f6a66a82383a2/
http://autobuild.buildroot.net/results/fff/fff0d6a814b765699cba803ececbc00d77e5d8fc/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tcpreplay/tcpreplay.mk

index b32810f78de45772270d737351ee569de6c0f4bf..0723c02d283661b830a018862b442ca69e9db8d3 100644 (file)
@@ -20,6 +20,10 @@ TCPREPLAY_LIBS = $(STAGING_DIR)/usr/bin/pcap-config --static --libs
 TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close="`$(TCPREPLAY_LIBS)`" \
        LIBS="`$(TCPREPLAY_LIBS)`"
 
+ifeq ($(BR2_STATIC_LIBS),y)
+TCPREPLAY_CONF_OPTS += --enable-dynamic-link=no
+endif
+
 ifeq ($(BR2_PACKAGE_TCPDUMP),y)
 TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=/usr/sbin/tcpdump
 else