ffmpeg: use arch and cpu instead of tune
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:27:10 +0000 (22:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 23:08:07 +0000 (00:08 +0100)
ffmpeg currently uses BR2_GCC_TARGET_TUNE as the --cpu option
value. However, there are multiple architectures for which
BR2_GCC_TARGET_TUNE is not used. After inspecting the ffmpeg configure
script, we concluded that using the BR2_GCC_TARGET_CPU value if
available, or the BR2_GCC_TARGET_ARCH value as a fallback was the
appropriate behavior.

This allows to remove the reference to BR2_GCC_TARGET_TUNE, which is
one step towards the removal of this option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 233797c4bac171bf6532e0ba61eb205aef7e32be..287f5e4976b27aec446e89386eeb7a004ba4509a 100644 (file)
@@ -340,6 +340,12 @@ endif
 
 FFMPEG_CONF_OPTS += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
 
+ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
+FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_CPU)
+else ifneq ($(call qstrip,$(BR2_GCC_TARGET_ARCH),)
+FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_ARCH)
+endif
+
 # Override FFMPEG_CONFIGURE_CMDS: FFmpeg does not support --target and others
 define FFMPEG_CONFIGURE_CMDS
        (cd $(FFMPEG_SRCDIR) && rm -rf config.cache && \
@@ -355,7 +361,6 @@ define FFMPEG_CONFIGURE_CMDS
                --target-os="linux" \
                --disable-stripping \
                --pkg-config="$(PKG_CONFIG_HOST_BINARY)" \
-               $(if $(BR2_GCC_TARGET_TUNE),--cpu=$(BR2_GCC_TARGET_TUNE)) \
                $(SHARED_STATIC_LIBS_OPTS) \
                $(FFMPEG_CONF_OPTS) \
        )