infrastructure: remove support for old style hooks
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Sep 2010 22:20:28 +0000 (00:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Sep 2010 17:26:54 +0000 (19:26 +0200)
Now that all old-style hooks occurences have been converted to
new-style hooks, let's get rid of the code needed to support old-style
hooks from the package infrastructure.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.package.in

index d76b7913d2dc403a0a923a5fcad8b34e5745728f..2c667df33bac2819a0740b2efdb43e86c273831c 100644 (file)
@@ -297,7 +297,7 @@ $(2)_TARGET_UNINSTALL =             $$($(2)_DIR)/.stamp_uninstalled
 $(2)_TARGET_CLEAN =            $$($(2)_DIR)/.stamp_cleaned
 $(2)_TARGET_DIRCLEAN =         $$($(2)_DIR)/.stamp_dircleaned
 
-# new-style hooks
+# post-steps hooks
 $(2)_POST_EXTRACT_HOOKS         ?=
 $(2)_POST_PATCH_HOOKS           ?=
 $(2)_POST_CONFIGURE_HOOKS       ?=
@@ -306,20 +306,13 @@ $(2)_POST_INSTALL_HOOKS         ?=
 $(2)_POST_INSTALL_STAGING_HOOKS ?=
 $(2)_POST_INSTALL_TARGET_HOOKS  ?=
 
-# old-style hooks
-$(2)_HOOK_POST_EXTRACT =       $$($(2)_DIR)/.stamp_hook_post_extract
-$(2)_HOOK_POST_CONFIGURE =     $$($(2)_DIR)/.stamp_hook_post_configure
-$(2)_HOOK_POST_BUILD =         $$($(2)_DIR)/.stamp_hook_post_build
-$(2)_HOOK_POST_INSTALL =       $$($(2)_DIR)/.stamp_hook_post_install
-
 # human-friendly targets and target sequencing
 $(1):                  $(1)-install
 
 ifeq ($$($(2)_TYPE),host)
-$(1)-install:          $(1)-install-host $$($(2)_HOOK_POST_INSTALL)
+$(1)-install:          $(1)-install-host
 else
-$(1)-install:          $(1)-install-staging $(1)-install-target \
-                       $$($(2)_HOOK_POST_INSTALL)
+$(1)-install:          $(1)-install-staging $(1)-install-target
 endif
 
 ifeq ($$($(2)_INSTALL_TARGET),YES)
@@ -339,18 +332,15 @@ endif
 $(1)-install-host:      $(1)-build $$($(2)_TARGET_INSTALL_HOST)
 
 $(1)-build:            $(1)-configure \
-                       $$($(2)_TARGET_BUILD) \
-                       $$($(2)_HOOK_POST_BUILD)
+                       $$($(2)_TARGET_BUILD)
 
 $(1)-configure:                $(1)-patch \
-                       $$($(2)_TARGET_CONFIGURE) \
-                       $$($(2)_HOOK_POST_CONFIGURE)
+                       $$($(2)_TARGET_CONFIGURE)
 
 $(1)-patch:            $(1)-extract $$($(2)_TARGET_PATCH)
 
 $(1)-extract:          $(1)-depends \
-                       $$($(2)_TARGET_EXTRACT) \
-                       $$($(2)_HOOK_POST_EXTRACT)
+                       $$($(2)_TARGET_EXTRACT)
 
 $(1)-depends:          $(1)-source $$($(2)_DEPENDENCIES)
 
@@ -380,17 +370,6 @@ $$($(2)_TARGET_SOURCE):                    PKG=$(2)
 $$($(2)_TARGET_UNINSTALL):             PKG=$(2)
 $$($(2)_TARGET_CLEAN):                 PKG=$(2)
 $$($(2)_TARGET_DIRCLEAN):              PKG=$(2)
-$$($(2)_HOOK_POST_EXTRACT):            PKG=$(2)
-$$($(2)_HOOK_POST_CONFIGURE):          PKG=$(2)
-$$($(2)_HOOK_POST_BUILD):              PKG=$(2)
-$$($(2)_HOOK_POST_INSTALL):            PKG=$(2)
-
-# define hook targets
-# default hook behaviour: do nothing
-$$($(2)_HOOK_POST_EXTRACT):
-$$($(2)_HOOK_POST_CONFIGURE):
-$$($(2)_HOOK_POST_BUILD):
-$$($(2)_HOOK_POST_INSTALL):
 
 # add package to the general list of targets if requested by the buildroot
 # configuration