package/mtools: new host-package
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Mar 2013 08:19:45 +0000 (08:19 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Mar 2013 22:11:45 +0000 (23:11 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in.host
package/mtools/Config.in.host [new file with mode: 0644]
package/mtools/mtools.mk [new file with mode: 0644]

index e97f6e8474044d6d8477d0423d6f4662589220d7..7c0dd201fa1ee005d5fa714c94b43d6e7c031870 100644 (file)
@@ -6,6 +6,7 @@ source "package/e2fsprogs/Config.in.host"
 source "package/genimage/Config.in.host"
 source "package/genpart/Config.in.host"
 source "package/lpc3250loader/Config.in.host"
+source "package/mtools/Config.in.host"
 source "package/omap-u-boot-utils/Config.in.host"
 source "package/openocd/Config.in.host"
 source "package/sam-ba/Config.in.host"
diff --git a/package/mtools/Config.in.host b/package/mtools/Config.in.host
new file mode 100644 (file)
index 0000000..d534b5e
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_MTOOLS
+       bool "host mtools"
+       help
+         Mtools is a collection of utilities to access MS-DOS disks from
+         Unix without mounting them. It supports Win'95 style long file
+         names, OS/2 Xdf disks and 2m disks (store up to 1992k on a high
+         density 3 1/2 disk).
+         
+         http://www.tux.org/pub/tux/mtools/
diff --git a/package/mtools/mtools.mk b/package/mtools/mtools.mk
new file mode 100644 (file)
index 0000000..a27c4fd
--- /dev/null
@@ -0,0 +1,17 @@
+#############################################################
+#
+# mtools
+#
+#############################################################
+
+MTOOLS_VERSION       = 4.0.18
+MTOOLS_SOURCE        = mtools-$(MTOOLS_VERSION).tar.bz2
+MTOOLS_SITE          = $(BR2_GNU_MIRROR)/mtools/
+MTOOLS_LICENSE       = GPLv3+
+MTOOLS_LICENSE_FILES = COPYING
+
+MTOOLS_CONF_OPT = --enable-xdf        \
+                  --enable-vold       \
+                  --enable-new-vold
+
+$(eval $(host-autotools-package))