gst1-libav: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Tue, 11 Feb 2014 14:25:20 +0000 (16:25 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Feb 2014 18:31:57 +0000 (19:31 +0100)
gst1-libav needs the same fix for xtensa like ffmpeg got in commit
4ec35e76b8a3 (ffmpeg: fix build for xtensa).

Fixes:
http://autobuild.buildroot.net/results/33f/33fcbb79809719f68f3ee2cdb0fcacad82b9e0eb/

[Peter: pass the correct flags, not the ones from ffmpeg]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-libav/gst1-libav.mk

index 1c45acc7377a8ed02f895ecfaab78f0e713dbc43..a0a536e9289c8e81cd46c261f1f9543fd7733019 100644 (file)
@@ -83,4 +83,12 @@ endif
 GST1_LIBAV_CONF_OPT = \
        --with-libav-extra-configure="$(GST1_LIBAV_CONF_EXTRA_OPT)"
 
+GST1_LIBAV_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_xtensa),y)
+GST1_LIBAV_CFLAGS += -mtext-section-literals
+endif
+
+GST1_LIBAV_CONF_ENV += CFLAGS="$(GST1_LIBAV_CFLAGS)"
+
 $(eval $(autotools-package))