package/belle-sip: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 27 Feb 2020 17:47:12 +0000 (18:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Mar 2020 21:13:11 +0000 (22:13 +0100)
Belle-sip is a modern library implementing SIP (RFC 3261) transport,
transaction and dialog layers.

http://www.linphone.org/technical-corner/belle-sip

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: select mbedtls as support for crypto is needed in bctoolbox]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/belle-sip/Config.in [new file with mode: 0644]
package/belle-sip/belle-sip.hash [new file with mode: 0644]
package/belle-sip/belle-sip.mk [new file with mode: 0644]

index 3316f701ce9ff01a0ecc65c3c216117541dd4271..4924856bf60987853a67a9fc29b3d12f1340b7d0 100644 (file)
@@ -827,6 +827,7 @@ F:  package/openzwave/
 
 N:     Fabrice Fontaine <fontaine.fabrice@gmail.com>
 F:     package/bearssl/
+F:     package/belle-sip/
 F:     package/boinc/
 F:     package/cairo/
 F:     package/duktape/
index 910b26698e502dca30f6022ff69c025dbeea3cb1..a41143670000c3e5bc8672375240c37557bf62fe 100644 (file)
@@ -1617,6 +1617,7 @@ menu "Networking"
        source "package/azmq/Config.in"
        source "package/azure-iot-sdk-c/Config.in"
        source "package/batman-adv/Config.in"
+       source "package/belle-sip/Config.in"
        source "package/bluez5_utils-headers/Config.in"
        source "package/c-ares/Config.in"
        source "package/canfestival/Config.in"
diff --git a/package/belle-sip/Config.in b/package/belle-sip/Config.in
new file mode 100644 (file)
index 0000000..8e4de36
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_BELLE_SIP
+       bool "belle-sip"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_STATIC_LIBS # dlfcn.h
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # bctoolbox
+       depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_BCTOOLBOX
+       # needs crypto support in bctoolbox
+       select BR2_PACKAGE_MBEDTLS
+       help
+         Belle-sip is a modern library implementing SIP (RFC 3261)
+         transport, transaction and dialog layers.
+
+         http://www.linphone.org/technical-corner/belle-sip
+
+comment "belle-sip needs a toolchain w/ threads, C++, dynamic library, wchar"
+       depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || \
+               !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+
+comment "belle-sip needs a toolchain not affected by GCC bug 64735"
+       depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
diff --git a/package/belle-sip/belle-sip.hash b/package/belle-sip/belle-sip.hash
new file mode 100644 (file)
index 0000000..889ad2b
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  3ac7051ea6ac758cccbf1483a5dd6cda4293b5cde1370a3f0d298e3a6f0ee032  belle-sip-4.3.1.tar.gz
+sha256  1b3782ccad7b8614100cda30d3faf42fc39f2e97932908c543005053b654ca68  LICENSE.txt
diff --git a/package/belle-sip/belle-sip.mk b/package/belle-sip/belle-sip.mk
new file mode 100644 (file)
index 0000000..1daef1d
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# belle-sip
+#
+################################################################################
+
+BELLE_SIP_VERSION = 4.3.1
+BELLE_SIP_SITE = \
+       https://gitlab.linphone.org/BC/public/belle-sip/-/archive/$(BELLE_SIP_VERSION)
+BELLE_SIP_LICENSE = GPL-3.0+
+BELLE_SIP_LICENSE_FILES = LICENSE.txt
+BELLE_SIP_INSTALL_STAGING = YES
+BELLE_SIP_DEPENDENCIES = \
+       bctoolbox \
+       $(if $(BR2_PACKAGE_ZLIB),zlib)
+BELLE_SIP_CONF_OPTS = \
+       -DENABLE_STRICT=OFF \
+       -DENABLE_TESTS=OFF
+
+ifeq ($(BR2_PACKAGE_AVAHI_LIBDNSSD_COMPATIBILITY),y)
+BELLE_SIP_CONF_OPTS += -DENABLE_MDNS=ON
+BELLE_SIP_DEPENDENCIES += avahi
+else
+BELLE_SIP_CONF_OPTS += -DENABLE_MDNS=OFF
+endif
+
+ifeq ($(BR2_STATIC_LIBS),y)
+BELLE_SIP_CONF_OPTS += -DENABLE_SHARED=OFF -DENABLE_STATIC=ON
+else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+BELLE_SIP_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=ON
+else ifeq ($(BR2_SHARED_LIBS),y)
+BELLE_SIP_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=OFF
+endif
+
+$(eval $(cmake-package))