projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c9d7729
)
Better deal with arches like mips that have odd kernel dir naming
author
Eric Andersen
<andersen@codepoet.org>
Fri, 27 Feb 2004 00:26:57 +0000
(
00:26
-0000)
committer
Eric Andersen
<andersen@codepoet.org>
Fri, 27 Feb 2004 00:26:57 +0000
(
00:26
-0000)
make/linux.mk
patch
|
blob
|
history
diff --git
a/make/linux.mk
b/make/linux.mk
index 2600afc01f6c92d5d30a621ad45f2b8dafcb93bb..442c55b3dc335a61a340597ff895101db022f78c 100644
(file)
--- a/
make/linux.mk
+++ b/
make/linux.mk
@@
-27,6
+27,11
@@
DOWNLOAD_LINUX_VERSION=2.4.23
LINUX_VERSION=2.4.23-erik
LINUX_FORMAT=bzImage
+LINUX_KARCH:= echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ sed -e 's/mipsel/mips/' \
+ sed -e 's/powerpc/ppc/' \
+ sed -e 's/sh[234]/sh/'
+LINUX_BINLOC=arch/$(LINUX_KARCH)/boot/$(LINUX_FORMAT)
LINUX_BINLOC=arch/$(ARCH)/boot/$(LINUX_FORMAT)
#LINUX_FORMAT=zImage
#LINUX_BINLOC=arch/ppc/boot/images/zImage.prep