package/libsquish: re-enable for BR2_STATIC_LIBS configuration
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 12 Jan 2019 14:34:32 +0000 (15:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 12 Jan 2019 14:35:37 +0000 (15:35 +0100)
Since the bump to version 1.15, libsquish can conditionally
build/install its shared library, which makes it possible to re-enable
this package for BR2_STATIC_LIBS configurations.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libsquish/Config.in
package/libsquish/libsquish.mk

index eabe6c54a8b8fa7c59f4cb76fc95497d08f40e37..e93e97e57884fc82a0f42dade28761e6f3fadf64 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_LIBSQUISH
        bool "libsquish"
        depends on BR2_INSTALL_LIBSTDCPP
-       depends on !BR2_STATIC_LIBS
        help
          The libSquish library compresses images with the DXT standard
          (also known as S3TC). This standard is mainly used by OpenGL
@@ -9,5 +8,5 @@ config BR2_PACKAGE_LIBSQUISH
 
          http://sourceforge.net/projects/libsquish
 
-comment "libsquish needs a toolchain w/ C++, dynamic library"
-       depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS
+comment "libsquish needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
index b1a80e5b60a4428c685977fdbba0b1f829fea79c..75d2cbd16a846c2b3fbd7bf2142e67877d9bc30f 100644 (file)
@@ -12,7 +12,11 @@ LIBSQUISH_STRIP_COMPONENTS = 0
 LIBSQUISH_LICENSE = MIT
 LIBSQUISH_LICENSE_FILES = LICENSE.txt
 
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBSQUISH_MAKE_ENV = USE_SHARED=0
+else
 LIBSQUISH_MAKE_ENV = USE_SHARED=1
+endif
 
 define LIBSQUISH_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(LIBSQUISH_MAKE_ENV) $(MAKE) -C $(@D)