cloop: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Mar 2010 21:35:44 +0000 (22:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:03:55 +0000 (11:03 +0200)
Only the host variant is supported, which explains why there is no
Config.in file. Will be used by the filesystem generation code.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cloop/cloop.mk [new file with mode: 0644]

diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
new file mode 100644 (file)
index 0000000..f1c1e1c
--- /dev/null
@@ -0,0 +1,18 @@
+CLOOP_VERSION=2.631-1
+CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
+CLOOP_SITE=http://debian-knoppix.alioth.debian.org/sources/
+
+HOST_CLOOP_DEPENDENCIES = host-zlib
+
+define HOST_CLOOP_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE1) \
+   CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
+endef
+
+define HOST_CLOOP_INSTALL_CMDS
+ install -m 755 $(@D)/create_compressed_fs $(HOST_DIR)/usr/bin
+ install -m 755 $(@D)/extract_compressed_fs $(HOST_DIR)/usr/bin
+endef
+
+$(eval $(call GENTARGETS,package,cloop))
+$(eval $(call GENTARGETS,package,cloop,host))
\ No newline at end of file