qwt: use TARGET_MAKE_ENV when running make and qmake
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 19 Mar 2014 19:30:07 +0000 (20:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Mar 2014 16:04:52 +0000 (17:04 +0100)
This patch prepends TARGET_MAKE_ENV to $(MAKE) and $(QT_QMAKE) command
lines, to make sure PATH is set correctly, and to line up with the qt5
packages that do this consistently.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qwt/qwt.mk

index aa5ec9bea96dded305a1cb5335d364e7c486cac6..776780b20775f642c0c9e183471e5adf4c72476c 100644 (file)
@@ -28,11 +28,11 @@ endif
 
 define QWT_CONFIGURE_CMDS
        $(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
-       (cd $(@D); $(QT_QMAKE))
+       (cd $(@D); $(TARGET_MAKE_ENV) $(QT_QMAKE))
 endef
 
 define QWT_BUILD_CMDS
-       $(MAKE) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
 # After installation, we fixup the INSTALL_PREFIX in qwtconfig.pri so