jquery-ui: use install -t to copy images to target
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 16 Jan 2015 07:53:30 +0000 (08:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 16 Jan 2015 08:00:10 +0000 (09:00 +0100)
Instead of cp + chmod as there may be other files in the destination
directory that chmod shouldn't change permissions of / where chmod might
fail (E.G. symlinks that are only valid on the target).

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jquery-ui/jquery-ui.mk

index e4d3370a951f3f41f1cad24517273bbfb1b69f4a..d829d6241bfff09decf3765dfb3c9427ec07240e 100644 (file)
@@ -27,9 +27,8 @@ define JQUERY_UI_INSTALL_TARGET_CMDS
        $(INSTALL) -m 0644 -D $(@D)/themes/base/minified/jquery-ui.min.css \
                $(TARGET_DIR)/var/www/jquery-ui.css
        $(INSTALL) -d $(TARGET_DIR)/var/www/images
-       cp -a $(@D)/themes/base/minified/images/*.png \
-               $(TARGET_DIR)/var/www/images
-       chmod 0644 $(TARGET_DIR)/var/www/images/*.png
+       $(INSTALL) -m 0644 -t $(TARGET_DIR)/var/www/images \
+               $(@D)/themes/base/minified/images/*.png
 endef
 
 $(eval $(generic-package))