imx-parser: add missing configure options
authorGary Bisson <gary.bisson@boundarydevices.com>
Wed, 27 Jul 2016 13:53:33 +0000 (15:53 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Aug 2016 20:07:01 +0000 (22:07 +0200)
Enable hard float support when the configuration contains:
BR2_ARM_EABIHF=y

See Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/blob/krogoth/recipes-multimedia/imx-parser/imx-parser.inc

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/imx-parser/imx-parser.mk

index 7dd14024919f55fae075c4a5e1eb1632aad810c0..e5797899b94c0982c9654a45a5354e67c399c64f 100644 (file)
@@ -13,6 +13,12 @@ IMX_PARSER_LICENSE = NXP Semiconductor Software License Agreement
 IMX_PARSER_LICENSE_FILES = EULA COPYING
 IMX_PARSER_REDISTRIBUTE = NO
 
+ifeq ($(BR2_ARM_EABIHF),y)
+IMX_PARSER_CONF_OPTS += --enable-fhw
+else
+IMX_PARSER_CONF_OPTS += --enable-fsw
+endif
+
 define IMX_PARSER_EXTRACT_CMDS
        $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_PARSER_SOURCE))
 endef