package/python-pylru: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 9 Oct 2016 12:46:19 +0000 (14:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Oct 2016 20:53:17 +0000 (22:53 +0200)
Needed by upcoming python-mwscrape package.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-pylru/Config.in [new file with mode: 0644]
package/python-pylru/python-pylru.hash [new file with mode: 0644]
package/python-pylru/python-pylru.mk [new file with mode: 0644]

index d418126d6aad4c3f41999ce750c169b7477d46f4..db4f72246c5fea84d9a1b722d3f8e6601b5e0a6b 100644 (file)
@@ -736,6 +736,7 @@ menu "External python modules"
        source "package/python-pygame/Config.in"
        source "package/python-pygments/Config.in"
        source "package/python-pyinotify/Config.in"
+       source "package/python-pylru/Config.in"
        source "package/python-pymysql/Config.in"
        source "package/python-pynacl/Config.in"
        source "package/python-pyopenssl/Config.in"
diff --git a/package/python-pylru/Config.in b/package/python-pylru/Config.in
new file mode 100644 (file)
index 0000000..c174576
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_PYLRU
+       bool "python-pylru"
+       help
+         A least recently used (LRU) cache implementation.
+
+         https://github.com/jlhutch/pylru
diff --git a/package/python-pylru/python-pylru.hash b/package/python-pylru/python-pylru.hash
new file mode 100644 (file)
index 0000000..806ea36
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/pylru/json, sha256 locally computed
+md5    41369d58a1c4391c5cc36f84262abcdc  pylru-1.0.9.tar.gz
+sha256 71376192671f0ad1690b2a7427d39a29b1df994c8469a9b46b03ed7e28c0172c  pylru-1.0.9.tar.gz
diff --git a/package/python-pylru/python-pylru.mk b/package/python-pylru/python-pylru.mk
new file mode 100644 (file)
index 0000000..e670f3d
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pylru
+#
+################################################################################
+
+PYTHON_PYLRU_VERSION = 1.0.9
+PYTHON_PYLRU_SOURCE = pylru-$(PYTHON_PYLRU_VERSION).tar.gz
+PYTHON_PYLRU_SITE = https://pypi.python.org/packages/c0/7d/0de1055632f3871dfeaabe5a3f0510317cd98b93e7b792b44e4c7de2b17b
+PYTHON_PYLRU_SETUP_TYPE = distutils
+PYTHON_PYLRU_LICENSE = GPLv2
+PYTHON_PYLRU_LICENSE_FILES = LICENSE.txt
+
+$(eval $(python-package))