xorg server: remove dependencies
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 13:27:47 +0000 (15:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Jul 2009 21:26:47 +0000 (23:26 +0200)
Currently, the X.org server selection always trigger the compilation
and installation of libXt (the X toolkit) and libXaw (Athena Widget
toolkits), which is are legacy toolkits not used by modern toolkits
(Gtk, Qt, etc.). They are only used by old X11 applications that are
typically not used on embedded systems.

Not compiling them save compilation time, and more importantly, space
on the target.

We also remove the compilation on xlib_libxkbui, libxmu and libxpm,
because they all depend on libXt.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 58bd8d2b45bee6d6273b8cd310bec25167b90bcd..105c790698c0c320bf5ea2578e8792caac8cde89 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        bool "xorg-server"
        select BR2_PACKAGE_XLIB_LIBXFONT
        select BR2_PACKAGE_LIBDRM
-       select BR2_PACKAGE_XLIB_LIBXKBUI
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_XPROTO_COMPOSITEPROTO
        select BR2_PACKAGE_XPROTO_DAMAGEPROTO
@@ -15,13 +14,10 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        select BR2_PACKAGE_XFONT_FONT_CURSOR_MISC if !BR2_PACKAGE_XSERVER_XORG_SERVER_BUILTIN_FONTS
        select BR2_PACKAGE_XLIB_LIBX11
        select BR2_PACKAGE_XLIB_LIBXAU
-       select BR2_PACKAGE_XLIB_LIBXAW
        select BR2_PACKAGE_XLIB_LIBXDMCP
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXFIXES
        select BR2_PACKAGE_XLIB_LIBXI
-       select BR2_PACKAGE_XLIB_LIBXMU
-       select BR2_PACKAGE_XLIB_LIBXPM
        select BR2_PACKAGE_XLIB_LIBXRENDER
        select BR2_PACKAGE_XLIB_LIBXRES
        select BR2_PACKAGE_XLIB_LIBXXF86MISC
index 0c70441662851df29ef0ddaf242b1f233c27a054..e2af32459aecf32950c8a9f1e49d0ff6931a13e7 100644 (file)
@@ -15,17 +15,13 @@ XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install
 XSERVER_XORG_SERVER_DEPENDENCIES =     \
        xutil_util-macros               \
        xlib_libXfont                   \
-       xlib_libxkbui                   \
        xlib_libX11                     \
        xlib_libXau                     \
-       xlib_libXaw                     \
        xlib_libXdmcp                   \
        xlib_libXScrnSaver              \
        xlib_libXext                    \
        xlib_libXfixes                  \
        xlib_libXi                      \
-       xlib_libXmu                     \
-       xlib_libXpm                     \
        xlib_libXrender                 \
        xlib_libXres                    \
        xlib_libXft                     \