libminiupnpc: New package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 2 Jul 2016 22:18:11 +0000 (00:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 3 Jul 2016 10:30:19 +0000 (12:30 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libminiupnpc/Config.in [new file with mode: 0644]
package/libminiupnpc/libminiupnpc.hash [new file with mode: 0644]
package/libminiupnpc/libminiupnpc.mk [new file with mode: 0644]

index 3fddf8e6d3eebe0da198464b9da625067c74f5a0..73bf32f0f11756aa196270acab9bf6db66760881 100644 (file)
@@ -1173,6 +1173,7 @@ menu "Networking"
        source "package/libmbus/Config.in"
        source "package/libmemcached/Config.in"
        source "package/libmicrohttpd/Config.in"
+       source "package/libminiupnpc/Config.in"
        source "package/libmnl/Config.in"
        source "package/libmodbus/Config.in"
        source "package/libndp/Config.in"
diff --git a/package/libminiupnpc/Config.in b/package/libminiupnpc/Config.in
new file mode 100644 (file)
index 0000000..c241707
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LIBMINIUPNPC
+       bool "libminiupnpc"
+       depends on !BR2_BINFMT_FLAT
+       depends on !BR2_STATIC_LIBS
+       help
+         The UPnP protocol is supported by most home adsl/cable routers
+         and Microsoft Windows 2K/XP. The aim of the MiniUPnP project is
+         to bring a free software solution to support the "Internet
+         Gateway Device" part of the protocol.
+
+         Miniupnpc aims at the simplest library possible, with the
+         smallest footprint and no dependencies to other libraries such
+         as XML parsers or HTTP implementations. All the code is pure
+         ANSI C.
+
+         http://miniupnp.free.fr
+
+comment "libminiupnpc needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
+       depends on !BR2_BINFMT_FLAT
diff --git a/package/libminiupnpc/libminiupnpc.hash b/package/libminiupnpc/libminiupnpc.hash
new file mode 100644 (file)
index 0000000..985d69d
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 d434ceb8986efbe199c5ca53f90ed53eab290b1e6d0530b717eb6fa49d61f93b  miniupnpc-2.0.tar.gz
diff --git a/package/libminiupnpc/libminiupnpc.mk b/package/libminiupnpc/libminiupnpc.mk
new file mode 100644 (file)
index 0000000..0eb7cf6
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libminiupnpc
+#
+################################################################################
+
+LIBMINIUPNPC_VERSION = 2.0
+LIBMINIUPNPC_SOURCE = miniupnpc-$(LIBMINIUPNPC_VERSION).tar.gz
+LIBMINIUPNPC_SITE = http://miniupnp.free.fr/files
+LIBMINIUPNPC_INSTALL_STAGING = YES
+LIBMINIUPNPC_LICENSE = BSD-3c
+LIBMINIUPNPC_LICENSE_FILES = LICENSE
+
+$(eval $(cmake-package))