wireshark: bump version to 2.2.0
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 8 Sep 2016 10:22:34 +0000 (11:22 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 8 Sep 2016 17:46:36 +0000 (19:46 +0200)
- Adapt current patch for 2.2.0.

- Adapt gtk configure options for 2.2.0:
  - Instead of --enable-gtk3 or --enable-gtk2, now it uses
    --enable-gtk=[no/2/3/yes].

- Remove non-existing configure options:
  - --enable-usr-local: removed by
    https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=125989780ba8e658ad0d1f1c71ec01e6d36a2266

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wireshark/0001-configure-do-not-assume-broken-inet_pton-in-case-of-.patch [deleted file]
package/wireshark/0001-configure.ac-do-not-assume-broken-inet_pton-in-case-.patch [new file with mode: 0644]
package/wireshark/wireshark.hash
package/wireshark/wireshark.mk

diff --git a/package/wireshark/0001-configure-do-not-assume-broken-inet_pton-in-case-of-.patch b/package/wireshark/0001-configure-do-not-assume-broken-inet_pton-in-case-of-.patch
deleted file mode 100644 (file)
index 4d1f680..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From a0657feeb2b349ffda895a53e36ea5c992d871cf Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Sat, 31 Oct 2015 22:38:48 +0100
-Subject: [PATCH] configure: do not assume broken inet_pton in case of cross
- compiling
-
-Patch configure.ac to not assume broken inet_pton in case of cross
-compiling.
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index aec0548..d640e0c 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2646,8 +2646,8 @@ int main()
- #endif
- }], [AC_MSG_RESULT(ok);
- have_inet_pton=yes], [AC_MSG_RESULT(broken);
--have_inet_pton=no], [AC_MSG_RESULT(cross compiling, assume it is broken);
--have_inet_pton=no])],
-+have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken... not here]);
-+have_inet_pton=yes])],
- have_inet_pton=no)
- if test "$have_inet_pton" = no; then
-   INET_PTON_LO="inet_pton.lo"
--- 
-2.1.4
-
diff --git a/package/wireshark/0001-configure.ac-do-not-assume-broken-inet_pton-in-case-.patch b/package/wireshark/0001-configure.ac-do-not-assume-broken-inet_pton-in-case-.patch
new file mode 100644 (file)
index 0000000..1e44ad0
--- /dev/null
@@ -0,0 +1,35 @@
+From 25d313275e87dc236e86c0e713cad08ea64253f8 Mon Sep 17 00:00:00 2001
+From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+Date: Thu, 8 Sep 2016 10:58:34 +0100
+Subject: [PATCH] configure.ac: do not assume broken inet_pton in case of cross
+ compiling
+
+Patch configure.ac to not assume broken inet_pton in case of cross
+compiling.
+
+[Vincent: adapt the patch for 2.2.0]
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c43e366..9672831 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2373,8 +2373,8 @@ int main()
+ #endif
+ }], [AC_MSG_RESULT(ok);
+ have_inet_pton=yes], [AC_MSG_RESULT(broken);
+-have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken]);
+-have_inet_pton=no])],
++have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken... not here]);
++have_inet_pton=yes])],
+ have_inet_pton=no)
+ if test "$have_inet_pton" = no; then
+   AC_LIBOBJ(inet_pton)
+-- 
+2.7.3
+
index fe4070bd528f7632b055bc463ff750d4d1d8d8c5..73e57cd545374bad31bdd4b555819304f7719996 100644 (file)
@@ -1,2 +1,2 @@
-# From: https://www.wireshark.org/download/src/all-versions/SIGNATURES-2.0.5.txt
-sha256 0ce0241330828973f5b4efee422a3760cab8ce0b41e7721c4b9fd185be1bb10b  wireshark-2.0.5.tar.bz2
+# From: https://www.wireshark.org/download/src/all-versions/SIGNATURES-2.2.0.txt
+sha256 a6847e741efcba6cb9d92d464d4219917bee3ad0b8f5b0f80d4388ad2f3f1104  wireshark-2.2.0.tar.bz2
index 42a5e74bc603b133110a93ea60af91008f52eab0..aa0c6d0b567ff928529a426408bd891f38f310df 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-WIRESHARK_VERSION = 2.0.5
+WIRESHARK_VERSION = 2.2.0
 WIRESHARK_SOURCE = wireshark-$(WIRESHARK_VERSION).tar.bz2
 WIRESHARK_SITE = http://www.wireshark.org/download/src/all-versions
 WIRESHARK_LICENSE = wireshark license
@@ -20,7 +20,6 @@ WIRESHARK_AUTORECONF = YES
 # Work around it by pointing includedir at staging
 WIRESHARK_CONF_OPTS = \
        --without-krb5 \
-       --disable-usr-local \
        --enable-static=no \
        --with-libsmi=no \
        --with-lua=no \
@@ -29,13 +28,13 @@ WIRESHARK_CONF_OPTS = \
 
 # wireshark GUI options
 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
-WIRESHARK_CONF_OPTS += --with-gtk3=yes
+WIRESHARK_CONF_OPTS += --with-gtk=3
 WIRESHARK_DEPENDENCIES += libgtk3
 else ifeq ($(BR2_PACKAGE_LIBGTK2),y)
-WIRESHARK_CONF_OPTS += --with-gtk2=yes
+WIRESHARK_CONF_OPTS += --with-gtk=2
 WIRESHARK_DEPENDECIES += libgtk2
 else
-WIRESHARK_CONF_OPTS += --with-gtk3=no --with-gtk2=no
+WIRESHARK_CONF_OPTS += --with-gtk=no
 endif
 
 # Qt4 needs accessibility, we don't support it