package/git: add optional support for gettext
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Mar 2017 12:43:14 +0000 (13:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Mar 2017 13:10:35 +0000 (14:10 +0100)
git links to libintl if available:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/bin/git | grep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [libintl.so.8]
 0x00000001 (NEEDED)                     Shared library: [libc.so.0]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/git/git.mk

index 1d70924ae84535b5ef7f0a4189d7240234ca4170..138a8b6038e68578e8930eade36c077733d584dd 100644 (file)
@@ -11,6 +11,10 @@ GIT_LICENSE = GPLv2, LGPLv2.1+
 GIT_LICENSE_FILES = COPYING LGPL-2.1
 GIT_DEPENDENCIES = zlib host-gettext
 
+ifeq ($(BR2_PACKAGE_GETTEXT),y)
+GIT_DEPENDENCIES += gettext
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 GIT_DEPENDENCIES += openssl
 GIT_CONF_OPTS += --with-openssl