projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c3e119e
)
package/php: Always link with libpthread for static builds
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Sun, 29 Nov 2015 13:55:51 +0000
(14:55 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 21:50:56 +0000
(22:50 +0100)
Fixes
http://autobuild.buildroot.net/results/c9f/
c9fb2b4a25817d6455472767819018a62281d5f9
/
http://autobuild.buildroot.net/results/a75/
a757edcfce00d3e52c6787f28dc31cbaf8d2d2ab
/
http://autobuild.buildroot.net/results/8df/
8df836b6c241954449544c7b4c74a1cb19e7ff7b
/
http://autobuild.buildroot.net/results/1b6/
1b6e571e307c2b190116601bade382c43e8d3858
/
http://autobuild.buildroot.net/results/aa3/
aa34b2326a0702093162eb1f9d7bdf9c7cf45311
/
http://autobuild.buildroot.net/results/74a/
74ae21d78f7ea9d71407accd3e43900af6766e68
/
http://autobuild.buildroot.net/results/7ec/
7ec28c23b3f12e5b7e2376c7913329d2a38dd232
/
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/php.mk
patch
|
blob
|
history
diff --git
a/package/php/php.mk
b/package/php/php.mk
index 5f87d0799cb678cdafaae2f334cd72efe5548af9..5bdd04ee6e487e9dbf2d1644b4eb862b5c61f9c9 100644
(file)
--- a/
package/php/php.mk
+++ b/
package/php/php.mk
@@
-29,6
+29,10
@@
ifeq ($(BR2_STATIC_LIBS),y)
PHP_CONF_ENV += LIBS="$(PHP_STATIC_LIBS)"
endif
+ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
+PHP_STATIC_LIBS += -lpthread
+endif
+
ifeq ($(BR2_TARGET_LOCALTIME),)
PHP_LOCALTIME = UTC
else
@@
-209,9
+213,6
@@
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_UNIXODBC),y)
PHP_CONF_OPTS += --with-pdo-odbc=unixODBC,$(STAGING_DIR)/usr
PHP_DEPENDENCIES += unixodbc
-ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
-PHP_STATIC_LIBS += -lpthread
-endif
endif
endif