dropbear: add options to disable wtmp / lastlog logging
authorWill Moore <will.moore@beraninstruments.com>
Tue, 25 Oct 2011 12:22:18 +0000 (13:22 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Oct 2011 09:24:30 +0000 (11:24 +0200)
Buildroot does not have wtmp or lastlog support by default so allow dropbear
to be configured to stop using them and hence to stop generating system log
error messages.

[Peter: invert to positive options, and disable by default]
Signed-off-by: Will Moore <will.moore@beraninstruments.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dropbear/Config.in
package/dropbear/dropbear.mk

index c30228f202b0f5b06b9de6b981a304e86ac67ab2..0903ad1602e3a25366569d4a3e8c44ff8f61c6c0 100644 (file)
@@ -23,3 +23,17 @@ config BR2_PACKAGE_DROPBEAR_SMALL
 
          Tradeoffs are slower hashes and ciphers, and disabling of the
          blowfish cipher and zlib.
+
+config BR2_PACKAGE_DROPBEAR_WTMP
+       bool "log dropbear access to wtmp"
+       depends on BR2_PACKAGE_DROPBEAR
+       help
+         Enable logging of dropbear access to wtmp. Notice that
+         Buildroot does not generate wtmp by default.
+
+config BR2_PACKAGE_DROPBEAR_LASTLOG
+       bool "log dropbear access to lastlog"
+       depends on BR2_PACKAGE_DROPBEAR
+       help
+         Enable logging of dropbear access to lastlog. Notice that
+         Buildroot does not generate lastlog by default.
index e9da42df072158b9c9fb94a5e355da38671478b7..bced0ef4e8762afd50060cc52b21f593cc31f57a 100644 (file)
@@ -46,6 +46,14 @@ DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
 DROPBEAR_DEPENDENCIES += zlib
 endif
 
+ifneq ($(BR2_PACKAGE_DROPBEAR_WTMP),y)
+DROPBEAR_CONF_OPT += --disable-wtmp
+endif
+
+ifneq ($(BR2_PACKAGE_DROPBEAR_LASTLOG),y)
+DROPBEAR_CONF_OPT += --disable-lastlog
+endif
+
 define DROPBEAR_INSTALL_TARGET_CMDS
        $(INSTALL) -m 755 $(@D)/dropbearmulti $(TARGET_DIR)/usr/sbin/dropbear
        for f in $(DROPBEAR_TARGET_BINS); do \