libiqrf: Bump to v0.1.2 + update build system.
authorMarek Belisko <marek.belisko@open-nandra.com>
Wed, 3 Jul 2013 20:51:20 +0000 (22:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jul 2013 13:37:23 +0000 (15:37 +0200)
v0.1.2 update build system from autotools to cmake.

[Thomas: add patch to ensure the CMake build system only checks for a
C compiler and not a C++ compiler]

Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libiqrf/libiqrf-use-only-c-language.patch [new file with mode: 0644]
package/libiqrf/libiqrf.mk

diff --git a/package/libiqrf/libiqrf-use-only-c-language.patch b/package/libiqrf/libiqrf-use-only-c-language.patch
new file mode 100644 (file)
index 0000000..2f1c23c
--- /dev/null
@@ -0,0 +1,29 @@
+Use only the C language
+
+libirqf is written completely in C, but by default, CMake assumes that
+both C and C++ are used, and therefore verifies that a C++ compiler is
+installed. This may not necessarily be the case for a C-only package
+in Buildroot.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/CMakeLists.txt
+===================================================================
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-project(iqrf)
+-
+ set (iqrf_version_major 0)
+ set (iqrf_version_minor 1)
+ set (iqrf_version_patch 2)
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,3 +1,5 @@
++project(iqrf C)
++
+ cmake_minimum_required(VERSION 2.8.1)
+ enable_testing()
index f2d5b4c8c43f008aa35b6fbc7205855d511f17ac..df4bb421d8c09edbe03f27239f919d21f25885d8 100644 (file)
@@ -4,11 +4,11 @@
 #
 ################################################################################
 
-LIBIQRF_VERSION = v0.1.0
+LIBIQRF_VERSION = v0.1.2
 LIBIQRF_SITE = http://github.com/nandra/libiqrf/tarball/$(LIBIQRF_VERSION)
 LIBIQRF_INSTALL_STAGING = YES
 
 LIBIQRF_DEPENDENCIES = libusb
 
-$(eval $(autotools-package))
+$(eval $(cmake-package))