u-boot: fix custom patch handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 13:38:27 +0000 (15:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 20:18:56 +0000 (22:18 +0200)
When U-Boot is enabled and no custom patch directory has been set,
then the current test:

  ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),"")

works. However, when U-Boot is not enabled, but still gets compiled
because mkimage is needed to build the kernel,
BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR is completely empty. It does not
even have quotes. So the test in fact needs to be:

 ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/u-boot/u-boot.mk

index 9eeea1d004f83c0cfff1543ae98613ac60eb4fab..7b6b2ce632e30d6e348d2998fbbb763b0d3d5bd8 100644 (file)
@@ -77,7 +77,7 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
        toolchain/patch-kernel.sh $(U_BOOT_DIR) boot/u-boot \
                u-boot-$(U_BOOT_VERSION)-\*.patch \
                u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
-ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),"")
+ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
        toolchain/patch-kernel.sh $(U_BOOT_DIR) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) u-boot-$(U_BOOT_VERSION)-\*.patch
 endif
        touch $@