dbus: audit support needs both audit and libcap-ng
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Dec 2015 16:27:59 +0000 (17:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Dec 2015 16:27:59 +0000 (17:27 +0100)
As was suggested by the <pkg>_DEPENDENCIES variable, the audit support
in DBus requires both audit and libcap-ng. However, it didn't take
care of the fact that libcap-ng must be enabled in the configuration
to depend on it, causing some build failures with the newly added
check.

DBus configure.ac confirms that both packages are needed to enable
audit support, so we simply fix the condition to only be true when
both BR2_PACKAGE_AUDIT *and* BR2_PACKAGE_LIBCAP_NG are true.

Fixes:

  http://autobuild.buildroot.org/results/239/23953cc66faecb65e9ebf1f6980924f823d736a2/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus/dbus.mk

index 3cdc42ae7fa37325fb3f05f235c7cb11484d98eb..33bfb31580ab2b9da83a9810532a0cbc19b5909a 100644 (file)
@@ -50,7 +50,7 @@ else
 DBUS_CONF_OPTS += --disable-selinux
 endif
 
-ifeq ($(BR2_PACKAGE_AUDIT),y)
+ifeq ($(BR2_PACKAGE_AUDIT)$(BR2_PACKAGE_LIBCAP_NG),yy)
 DBUS_CONF_OPTS += --enable-libaudit
 DBUS_DEPENDENCIES += audit libcap-ng
 else