package/ffmpeg: add optional dependency to libebur128
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 24 Jul 2016 15:53:18 +0000 (17:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jul 2016 19:57:07 +0000 (21:57 +0200)
ebur128 support depends on gpl support in ffmpeg:
http://git.videolan.org/?p=ffmpeg.git;a=blob;f=configure;h=ec4ff083dd373bce34869b67189905e2822b848b;hb=refs/heads/release/2.8#l2747

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index a4e2be6ce096ce3eda025932e8216de1cd991fa0..c42336f80077014fd01bf1df557b47e45ab8c1be 100644 (file)
@@ -224,6 +224,10 @@ else
 FFMPEG_CONF_OPTS += --disable-libdcadec
 endif
 
+ifeq ($(BR2_PACKAGE_FFMPEG_GPL)$(BR2_PACKAGE_LIBEBUR128),yy)
+FFMPEG_DEPENDENCIES += libebur128
+endif
+
 ifeq ($(BR2_PACKAGE_LIBOPENH264),y)
 FFMPEG_CONF_OPTS += --enable-libopenh264
 FFMPEG_DEPENDENCIES += libopenh264