pkg-perl: prevents the interactive prompts
authorFrancois Perrad <fperrad@gmail.com>
Thu, 20 Mar 2014 18:35:42 +0000 (19:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 09:30:31 +0000 (10:30 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-perl.mk

index fdf1580fa26c1040e416f884c7d2cdbfad91e6d7..447f364e05448b2da34f477a4484d36f910dfc6b 100644 (file)
@@ -49,6 +49,7 @@ ifeq ($(4),target)
 # Configure package for target
 define $(2)_CONFIGURE_CMDS
        cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+               PERL_MM_USE_DEFAULT=1 \
                perl Build.PL \
                        --config ar="$(TARGET_AR)" \
                        --config full_ar="$(TARGET_AR)" \
@@ -68,6 +69,7 @@ define $(2)_CONFIGURE_CMDS
                        --install_path libdoc=/usr/share/man/man3 \
                        $$($(2)_CONF_OPT); \
        else \
+               PERL_MM_USE_DEFAULT=1 \
                PERL_AUTOINSTALL=--skipdeps \
                perl Makefile.PL \
                        AR="$(TARGET_AR)" \
@@ -93,11 +95,13 @@ else
 # Configure package for host
 define $(2)_CONFIGURE_CMDS
        cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+               PERL_MM_USE_DEFAULT=1 \
                perl Build.PL \
                        --install_base $$(HOST_DIR)/usr \
                        --installdirs vendor \
                        $$($(2)_CONF_OPT); \
        else \
+               PERL_MM_USE_DEFAULT=1 \
                PERL_AUTOINSTALL=--skipdeps \
                perl Makefile.PL \
                        INSTALL_BASE=$$(HOST_DIR)/usr \