ncurses: enable shared library build on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Mar 2013 22:26:37 +0000 (22:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Mar 2013 12:47:20 +0000 (13:47 +0100)
On the host, we generally build and install a shared library rather
than a static version of libraries. In this specific case, we will
want to build host-gettext, which builds a shared library that depends
on ncurses. And this doesn't work well if ncurses is static because it
hasn't been built with -fPIC. Therefore, let's build ncurses as shared
on the host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ncurses/ncurses.mk

index c01dfbc36b952f78f7072a53d6d29e264cc51c9a..eb47c3695be7646542caa20c91d5f0bf46a23fa0 100644 (file)
@@ -116,7 +116,7 @@ define HOST_NCURSES_BUILD_CMDS
 endef
 
 HOST_NCURSES_CONF_OPT = \
-       --without-shared --without-gpm \
+       --with-shared --without-gpm \
        --without-manpages \
        --without-cxx \
        --without-cxx-binding \