gdb: bump to 7.8.1
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Dec 2014 13:43:29 +0000 (14:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 29 Dec 2014 14:58:28 +0000 (15:58 +0100)
This commit bumps to 7.8.1, and updates the logic to use .tar.xz
tarballs so that it applies to all 7.8.x versions.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/Config.in.host
package/gdb/gdb.mk

index 1e20cd2ffa08db30cab8b0a72bc4ec3ef980d09d..e8402b7e582cf0290998036c5e79192bf1be8a0b 100644 (file)
@@ -55,4 +55,4 @@ config BR2_GDB_VERSION
        default "arc-2014.08-gdb" if BR2_arc
        default "6be65fb56ea6694a9260733a536a023a1e2d4d57" if BR2_microblaze
        default "7.7.1"    if BR2_GDB_VERSION_7_7 || !BR2_PACKAGE_HOST_GDB
-       default "7.8"      if BR2_GDB_VERSION_7_8
+       default "7.8.1"    if BR2_GDB_VERSION_7_8
index aa22193cfe6de156b30be6708b34d917361e6759..24084b81c0cb89022d30852eab712b9b10198a02 100644 (file)
@@ -23,7 +23,9 @@ ifeq ($(GDB_VERSION),6.7.1-avr32-2.1.5)
 GDB_SITE = ftp://www.at91.com/pub/buildroot
 endif
 
-ifeq ($(GDB_VERSION),7.8)
+# Starting from 7.8.x, bz2 tarballs no longer available, use .tar.xz
+# instead.
+ifneq ($(filter 7.8.%,$(GDB_VERSION)),)
 GDB_SOURCE = gdb-$(GDB_VERSION).tar.xz
 endif