ccache:
authorWade Berrier <wberrier@gmail.com>
Mon, 6 Oct 2008 19:14:41 +0000 (19:14 -0000)
committerWade Berrier <wberrier@gmail.com>
Mon, 6 Oct 2008 19:14:41 +0000 (19:14 -0000)
-Allow user to specify custom ccache location.

This allows you to build a toolchain and put it on
 an nfs share so other people can use the toolchain
 without errors about the ccache dir missing.

toolchain/ccache/Config.in
toolchain/ccache/ccache.mk

index 95f3a9c1ace975dbc7a74552aeaa0a5bbd1d9608..3d3e2ed50ee9cd440c1a3e4a3ed103597b44ac34 100644 (file)
@@ -7,3 +7,13 @@ config BR2_CCACHE
        help
            Enable ccache support?
 
+config BR2_CCACHE_DIR
+       string "ccache dir location?"
+       depends on BR2_CCACHE
+       default "$(TOOL_BUILD_DIR)/ccache-$(CCACHE_VER)/cache"
+       help
+           Where ccache should store cached files.
+
+comment "ccache dir location?       - disabled (requires ccache support)"
+       depends on !BR2_CCACHE
+
index 945f840569d85f74e6b03c5b630a8f0f951a7daa..c405e88ac7e968f36944e931f1378b128e3b4efc 100644 (file)
@@ -24,8 +24,9 @@ $(CCACHE_DIR1)/.patched: $(CCACHE_DIR1)/.unpacked
        # Should probably patch things to use a relative path.
        $(SED) "s,getenv(\"CCACHE_PATH\"),\"$(STAGING_DIR)/usr/bin-ccache\",g" \
                $(CCACHE_DIR1)/execute.c
-       # WARNING - this will break if the toolchain build dir is deleted.
-       $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(CCACHE_DIR1)/cache\",g" \
+       # WARNING - this will break if the toolchain build dir is deleted
+       #       when using the default cache dir location.
+       $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(BR2_CCACHE_DIR)\",g" \
                $(CCACHE_DIR1)/ccache.c
        mkdir -p $(CCACHE_DIR1)/cache
        touch $@