gdb: also force ELF support for gdbhost
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 24 Jan 2012 11:46:37 +0000 (12:46 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 24 Jan 2012 11:46:37 +0000 (12:46 +0100)
Similar to how we do for target (ee39d53ce3ee (Fix GDB BFD test linking)).

Gdb comes with an embedded copy of libiberty, but binutils also installs
libiberty.a into HOST_DIR. The gdb configure script tries to link against
this one rather than the gdb version when it checks for ELF support.
This may fail if those versions are not compatible, leading to obscure
error messages from gdb at runtime such as:

I'm sorry, Dave, I can't do that. Symbol format `elf32-$ARCH' unknown.

Fix it by forcing ELF support.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gdb/gdb.mk

index 85b892fdf47c01265da6c741fc38092ad434e489..56faf499770e8c7428b02524d3a8e20371dd9122 100644 (file)
@@ -195,6 +195,8 @@ $(GDB_HOST_DIR)/.configured: $(GDB_DIR)/.unpacked
        touch $@
 
 $(GDB_HOST_DIR)/gdb/gdb: $(GDB_HOST_DIR)/.configured
+       # force ELF support since it fails due to BFD linking problems
+       gdb_cv_var_elf=yes \
        $(MAKE) -C $(GDB_HOST_DIR)
        strip $(GDB_HOST_DIR)/gdb/gdb