yaboot: drop support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 24 Mar 2010 21:37:40 +0000 (22:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 10 Jun 2010 19:05:12 +0000 (21:05 +0200)
Yaboot does not build, hasn't been updated since a long time, and
isn't very common these days on embedded PowerPC platforms.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/Config.in
boot/yaboot/Config.in [deleted file]
boot/yaboot/yaboot.mk [deleted file]

index 6f2796f0ca1d3a336b31ccfacd11c6658c8dfaba..78ff82c965373d14449c1446904d095021d0ee98 100644 (file)
@@ -3,7 +3,6 @@ menu "Bootloaders"
 source "boot/grub/Config.in"
 source "boot/grub2/Config.in"
 source "boot/syslinux/Config.in"
-source "boot/yaboot/Config.in"
 source "boot/u-boot/Config.in"
 source "boot/at91bootstrap/Config.in"
 source "boot/at91dataflashboot/Config.in"
diff --git a/boot/yaboot/Config.in b/boot/yaboot/Config.in
deleted file mode 100644 (file)
index 75da815..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_TARGET_YABOOT
-       bool "yaboot"
-       depends on BR2_powerpc
-       help
-         The yaboot bootloader for new world powerpc systems.
diff --git a/boot/yaboot/yaboot.mk b/boot/yaboot/yaboot.mk
deleted file mode 100644 (file)
index cbeae50..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-ifeq ($(ARCH),powerpc)
-
-#############################################################
-#
-# yaboot
-#
-#############################################################
-
-YABOOT_SOURCE:=yaboot-1.3.13.tar.gz
-YABOOT_SITE:=http://penguinppc.org/bootloaders/yaboot
-YABOOT_DIR:=$(BUILD_DIR)/yaboot-1.3.13
-
-$(DL_DIR)/$(YABOOT_SOURCE):
-        $(call DOWNLOAD,$(YABOOT_SITE),$(YABOOT_SOURCE))
-
-yaboot-source: $(DL_DIR)/$(YABOOT_SOURCE)
-
-$(YABOOT_DIR)/Makefile: $(DL_DIR)/$(YABOOT_SOURCE)
-       $(ZCAT) $(DL_DIR)/$(YABOOT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
-       touch -c $(YABOOT_DIR)/Makefile
-
-$(YABOOT_DIR)/second/yaboot: $(YABOOT_DIR)/Makefile
-       $(MAKE) -C $(YABOOT_DIR) CROSS=$(TARGET_CROSS)
-       touch -c $(YABOOT_DIR)/second/yaboot
-
-yaboot: $(YABOOT_DIR)/second/yaboot
-
-yaboot-clean:
-       $(MAKE) -C $(YABOOT_DIR) clean
-
-yaboot-dirclean:
-       rm -rf $(YABOOT_DIR)
-
-endif
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_YABOOT),y)
-TARGETS+=yaboot
-endif
-